Здравствуйте!!!!
Помогите, пожалуйста, настроить Циску так, чтобы при падении основного канала автоматически трафик переходил на резервный канал.
Понимаю, что информации много по этому вопросу, но мои усилия к успеху не приводят!!!((((Вот кусок конфига:
!version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname cisco1841
!
boot-start-marker
boot-end-marker
!no aaa new-model
no ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip domain name yourdomain.com
ip name-server 212.188.4.10
ip name-server 195.34.32.116
ip name-server 81.200.0.1
ip name-server 81.200.2.222
!
!
!
interface FastEthernet0/0
description Lan
ip address 192.168.0.50 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
description Inet$ETH-WAN$
ip address 81.195.x.46 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0/0
description InetSU29
!
interface FastEthernet0/0/1
shutdown
!
interface FastEthernet0/0/2
shutdown
!
interface FastEthernet0/0/3
shutdown
!
interface Vlan1
description InetSU29
ip address 81.200.x.5 255.255.255.0
ip nat outside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 81.195.x.45
ip route 0.0.0.0 0.0.0.0 81.200.x.1 2
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map RMAP_NAT_FA0/0/0 interface Vlan1 overload
ip nat inside source route-map RMAP_NAT_FA0/1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
route-map RMAP_NAT_FA0/0/0 permit 100
match ip address list 1
match interface Vlan1
!
route-map RMAP_NAT_FA0/1 permit 100
match ip address list 1
match interface FastEthernet0/1
!
!
!
control-plane
!
!
scheduler allocate 20000 1000
end
> match ip address list 1Одну ошибку нашел, то что сверху исправил на:
match ip address 1Пингует шлюз провайдера, а дальше идти не хочет.
Вот что показывает sh ip route:
Gateway of last resort is 81.200.х.1 to network 0.0.0.0
81.0.0.0/24 is subnetted, 1 subnets
C 81.200.х.0 is directly connected, Vlan1
C 192.168.0.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [2/0] via 81.200.х.1
interface FastEthernet0/1
description Inet$ETH-WAN$
ip address 81.195.х.46 255.255.255.252
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/1
duplex auto
speed autoсюда добавил ip policy route-map RMAP_NAT_FA0/1
interface Vlan1
description InetSU29
ip address 81.200.х.5 255.255.255.0
ip nat outside
ip virtual-reassembly
ip policy route-map RMAP_NAT_FA0/0/0а сюда ip policy route-map RMAP_NAT_FA0/0/0
получил:
cisco1841#show ip policy
Interface Route map
Fa0/1 RMAP_NAT_FA0/1
Vlan1 RMAP_NAT_FA0/0/0