installf - add a file to the software installation database
installf [-c class] [ [-M] -R root_path] [-V fs_file] pkginst pathname [ftype [major minor] [mode owner group]]
installf [-c class] [ [-M] -R root_path] [-V fs_file] pkginst -
installf -f [-c class] [ [-M] -R root_path] [-V fs_file] pkginst
installf informs the system that a pathname not listed in the pkgmap(4) file is being created or modified. It should be invoked before any file modifications have occurred.
When the second synopsis is used, the pathname descriptions will be read from standard input. These descriptions are the same as would be given in the first synopsis but the information is given in the form of a list. The descriptions should be in the form:
pathname [ ftype [ major minor ] [ mode owner group ]]
After all files have been appropriately created and/or modified, installf should be invoked with the -f synopsis to indicate that installation is final. Links will be created at this time and, if attribute information for a pathname was not specified during the original invocation of installf, or was not already stored on the system, the current attribute values for the pathname will be stored. Otherwise, installf verifies that attribute values match those given on the command line, making corrections as necessary. In all cases, the current content information is calculated and stored appropriately.
Package commands are largefile(5)-aware. They handle files larger than 2 GB in the same way they handle smaller files. In their current implementations, pkgadd(1M), pkgtrans(1) and other package commands can process a datastream of up to 4 GB.
-c class
-f
-M
-R root_path
installf inherits the value of the PKG_INSTALL_ROOT environment variable. (See ENVIRONMENT VARIABLES, below.) If PKG_INSTALL_ROOT is set, such as when the -R option is used with pkgadd(1M) or pkgrm(1M), there is no need to use the installf -R option.
Note -
-V fs_file
pkginst
pathname
ftype
b
c
d
e
f
l
p
s
v
x
major
minor
mode
owner
group
Example 1 Basic Usage
The following example shows the use of installf, invoked from an optional pre-install or post-install script:
# create /dev/xt directory # (needs to be done before drvinstall) installf $PKGINST /dev/xt d 755 root sys || exit 2 majno=`/usr/sbin/drvinstall -m /etc/master.d/xt -d $BASEDIR/data/xt.o -v1.0` || exit 2 i=00 while [ $i -lt $limit ] do for j in 0 1 2 3 4 5 6 7 do echo /dev/xt$i$j c $majno `expr $i ? 8 + $j` 644 root sys | echo /dev/xt$i$j=/dev/xt/$i$j done i=`expr $i + 1` [ $i -le 9 ] && i="0$i" #add leading zero done | installf $PKGINST - || exit 2 # finalized installation, create links installf -f $PKGINST || exit 2
installf inherits the value of the following environment variable. This variable is set when pkgadd(1M) or pkgrm(1M) is invoked with the -R option.
PKG_INSTALL_ROOT
0
>0
See attributes(5) for descriptions of the following attributes:
|
pkginfo(1), pkgmk(1), pkgparam(1), pkgproto(1), pkgtrans(1), pkgadd(1M), pkgask(1M), pkgchk(1M), pkgrm(1M), removef(1M), pkgmap(4), space(4), attributes(5), largefile(5)
When ftype is specified, all applicable fields, as shown below, must be defined:
|
The installf command will create directories, named pipes and special devices on the original invocation. Links are created when installf is invoked with the -f option to indicate installation is complete.
Links should be specified as path1=path2. path1 indicates the destination and path2 indicates the source file.
Files installed with installf will be placed in the class none, unless a class is defined with the command. Subsequently, they will be removed when the associated package is deleted. If this file should not be deleted at the same time as the package, be certain to assign it to a class which is ignored at removal time. If special action is required for the file before removal, a class must be defined with the command and an appropriate class action script delivered with the package.
When classes are used, installf must be used in one of the following forms:
installf -c class1 ... installf -f -c class1 ... installf -c class2 ... installf -f -c class2 ...
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |