The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск дистрибутива NixOS 23.11, использующего пакетный менеджер Nix "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск дистрибутива NixOS 23.11, использующего пакетный менеджер Nix "  +/
Сообщение от opennews (??), 30-Ноя-23, 22:24 
Представлен выпуск дистрибутива NixOS 23.11, основанного на пакетном менеджере Nix и предоставляющего ряд собственных разработок, упрощающих настройку и сопровождение системы. Например, в  NixOS вся настройка системы происходит посредством единого файла системной конфигурации (configuration.nix), предоставляется возможность быстрого отката системы на предыдущую версию конфигурации, присутствует поддержка переключения между различными состояниями системы, поддерживается установка индивидуальных пакетов отдельными пользователями, есть возможность одновременного использования нескольких версий одной программы, обеспечены воспроизводимые сборки. Размер полного установочного образа с KDE 2.5 ГБ, GNOME - 2.4 ГБ, сокращённого консольного варианта - 990 МБ...

Подробнее: https://www.opennet.me/opennews/art.shtml?num=60209

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +3 +/
Сообщение от Аноним (1), 30-Ноя-23, 22:24 
> Добавлено 49 новых сервисов, среди которых […] NNCP
> В LXD добавлена поддержка виртуальных машин, помимо контейнеров.

Это же замечательно! Можно поудалять немного кода.

Поздравляю всех пользователей и хейтеров!

Ответить | Правка | Наверх | Cообщить модератору

2. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +7 +/
Сообщение от Аноним (2), 30-Ноя-23, 22:25 
>вся настройка системы происходит посредством единого файла системной конфигурации (configuration.nix),

Вот это я понимаю уникальное торговое предложение (УТП).
Ванную что сабж вытиснит все остальные дистры.

Ответить | Правка | Наверх | Cообщить модератору

3. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Аноним (3), 30-Ноя-23, 22:50 
> Ванную что сабж вытиснит все остальные дистры.

Что ванную? И на что готов поспорить что ты не ошибся, как обычно?

Ответить | Правка | Наверх | Cообщить модератору

6. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +3 +/
Сообщение от Аноним (6), 30-Ноя-23, 22:58 
Ты им попользуйся и поймешь. Первые пару месяцув прикольно, но потом тебе внезапно надо собрать сторонний пакет руками и начинаются пляски с бубном.

Решение интересное для "встроенных" систем с простым откатом обновлений.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

7. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +5 +/
Сообщение от Аноним (1), 30-Ноя-23, 23:03 
> но потом тебе внезапно надо собрать сторонний пакет руками

И ты добавляешь десяток строк на Nix. Но чаще всего нужно даже не сторонний пакет собрать, а поменять параметры сборки или версию у уже существующего, что и вовсе может быть решено в одну строчку. И никаких плясок с бубном.

Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Аноним (11), 30-Ноя-23, 23:51 
В целом так оно и есть, но вот со сторонними питоновскими приложениями - полный аллес, особенно если они активно используют CUDA и прочие AI-related пакеты из пипа, которых в nixpkgs либо нет, либо они слишком старые/новые, либо там отсутствует CUDA (xformers например).

Я пытался честно использовать максимум пакетов из nixpkgs, а все остальное собирать из сорцов. Но это заняло слишком много времени, а приложение в итоге выдавало негуглящиеся ошибки, потому что какая-то из либ должна была быть строго такой-то версии. В итоге плюнул и запакетировал через poetry2nix со включенным preferWheels = true. Волшебная вещь, как и сам poetry (поддерживает lock-файлы! оказалось, что в питоне они до сих пор в диковинку).

Ответить | Правка | Наверх | Cообщить модератору

12. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Аноним (1), 01-Дек-23, 00:11 
Понимаю твою боль очень хорошо. Без Poetry действительно тяжко, и тут никакой Nix не спасёт.
Ответить | Правка | Наверх | Cообщить модератору

14. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от morphe (?), 01-Дек-23, 04:12 
> В целом так оно и есть, но вот со сторонними питоновскими приложениями - полный аллес, особенно если они активно используют CUDA и прочие AI-related пакеты из пипа, которых в nixpkgs либо нет, либо они слишком старые/новые, либо там отсутствует CUDA (xformers например).

Попытка собрать AI пакет по requirements.txt даже без nix чаще проваливается чем из коробки работает

Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

31. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Местный Эксперт (?), 01-Дек-23, 10:32 
>[оверквотинг удален]
> - полный аллес, особенно если они активно используют CUDA и прочие
> AI-related пакеты из пипа, которых в nixpkgs либо нет, либо они
> слишком старые/новые, либо там отсутствует CUDA (xformers например).
> Я пытался честно использовать максимум пакетов из nixpkgs, а все остальное собирать
> из сорцов. Но это заняло слишком много времени, а приложение в
> итоге выдавало негуглящиеся ошибки, потому что какая-то из либ должна была
> быть строго такой-то версии. В итоге плюнул и запакетировал через poetry2nix
> со включенным preferWheels = true. Волшебная вещь, как и сам poetry
> (поддерживает lock-файлы! оказалось, что в питоне они до сих пор в
> диковинку).

Ну так а в итоге то что, какой дистр в итоге самый готовый из коробки для этого получается, где не надо вот это всё затягивать руками и компилять?!
А то интригу создал и ходишь вокруг да около. xD

Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

43. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Минона (ok), 01-Дек-23, 13:20 
Убунта.
Ответить | Правка | Наверх | Cообщить модератору

90. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Заноним (?), 02-Дек-23, 20:43 
Ложь
Ответить | Правка | Наверх | Cообщить модератору

21. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 07:20 
помню-помню, как мне вместе с паспортом дали знания древних - языка nix, который нигде кроме nixpkgs и не применяется. А раз уж дали - то чего бы эти знания не использовать, учить-то ничего не надо - вот они готовенькие
Ответить | Правка | К родителю #7 | Наверх | Cообщить модератору

33. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (33), 01-Дек-23, 11:00 
> который нигде кроме nixpkgs и не применяется

Ложь.
Как минимум раз: https://github.com/ton-blockchain/ton/blob/master/flake.nix два: https://github.com/hyprwm/Hyprland/blob/main/flake.nix

Ответить | Правка | Наверх | Cообщить модератору

39. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 11:59 
>> который нигде кроме nixpkgs и не применяется
> Ложь.
> Как минимум раз: https://github.com/ton-blockchain/ton/blob/master/flake.nix два:
> https://github.com/hyprwm/Hyprland/blob/main/flake.nix

ложь это когда ты шыворот-навыворот приносишь такие ссылки. Без nixpkgs у этих флейков какое практическое применение? дай угадаю, никакое

Ответить | Правка | Наверх | Cообщить модератору

44. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  –1 +/
Сообщение от Аноним (33), 01-Дек-23, 13:53 
> Без nixpkgs у этих флейков какое практическое применение? дай угадаю, никакое

Так можно сказать про любую зависимость, это не аргумент

Ответить | Правка | Наверх | Cообщить модератору

50. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Минона (ok), 01-Дек-23, 14:50 
> Nixpkgs is a collection of over 80,000 software packages that can be installed with the Nix package manager.
> Flakes is a feature of managing Nix packages to simplify usability and improve reproducibility of Nix installations.
Ответить | Правка | Наверх | Cообщить модератору

62. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Вася (??), 01-Дек-23, 16:32 
> Так можно сказать про любую зависимость, это не аргумент

Это щас было примерно как:
"чехлы для айфона не нужны нигде кроме айфонов" -
"лошь! вот они, чехлы для айфонов продаются в магазине - значит они нужны что бы продаваться в магазине!", т.е. причина со следствием наглухо перепутана

Ответить | Правка | К родителю #44 | Наверх | Cообщить модератору

63. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  –1 +/
Сообщение от Аноним (33), 01-Дек-23, 16:52 
Вот от аналогия получше, может хоть что-то понятнее станет:

"язык Rust нигде не нужен кроме std"
"нет, вот ссылки на файл Cargo.toml в проектах где используется язык Rust (какой ужас, с использованием std, да)"

т.е. у вас понимание аналогизируемых сущностей наглухо отсутствует

Ответить | Правка | Наверх | Cообщить модератору

71. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 17:28 
> Вот от аналогия получше, может хоть что-то понятнее станет:
> "язык Rust нигде не нужен кроме std"
> "нет, вот ссылки на файл Cargo.toml в проектах где используется язык Rust
> (какой ужас, с использованием std, да)"
> т.е. у вас понимание аналогизируемых сущностей наглухо отсутствует

только вот есть нюанс, в проектах с Rust и Cargo.toml это будет неотъемлимая часть, а флейки от никса из проектов, где используется rust, можно выкинуть и собрать все то же самое на любом другом дистрибутиве, поэтому у кого тут чо наглухо отсутствует это еще вопрос

Ответить | Правка | Наверх | Cообщить модератору

73. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 18:43 
Если ты в приципе умеешь программировать и знаешь хотя бы пару ЯП, то с Nix разберёшься за пару часов. Я почти уверен, что никаких сложных и уникальных задач у тебя нет, и примеры из документации подойдут с минимальными правками. А на случай, когда документации не хватает или что-то неясно, есть коммьюнити, где новичкам рады помочь. Тем более, что большая часть конфигов в реальности сводится к банальному «service.something.enable = true;», что не сложнее любого другого файла из /etc. И даже если где-то вместо итерации по массиву ты просто накопипастишь кучу строк, ничего страшного не произойдёт, никто с тебя смеяться не будет, не переживай.
Ответить | Правка | К родителю #21 | Наверх | Cообщить модератору

83. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 02-Дек-23, 12:44 
> Если ты в приципе умеешь программировать и знаешь хотя бы пару ЯП,
> то с Nix разберёшься за пару часов.

угу, особенно напрактикуешься им так, что синтаксис сам будет от пальцев отскакивать бггг
на конфиг файлах, конечно же!

> Я почти уверен, что
> никаких сложных и уникальных задач у тебя нет, и примеры из
> документации подойдут с минимальными правками.

В целом так и есть, но есть нюанс - там где у меня такие задачи есть, я nixos и не поставлю в данный момент времени.
Так же я ее не поставлю там, где доступ к ремонту систем нужно давать наблатыканным линуксоидам, которые знать не знают, чо это ваш за nixos такой и в основном системы тока в виртуалках видели.

> А на случай, когда документации не хватает или что-то неясно, есть коммьюнити, где новичкам рады помочь.

да нормальное коммунити, внезапно.
беда в том, что порог входа адовый: у тебя может быть 10+ лет опыта работы с линуксами, а после nixos ты такой: "блин, а как тут ходить? попробовал WASD, не получается!"


> Тем более, что большая часть конфигов в реальности сводится к банальному «service.something.enable
> = true;», что не сложнее любого другого файла из /etc.

Это большая часть. Когда тебе нужно что-то кроме - сидишь и часами решаешь, как это завести.

> даже если где-то вместо итерации по массиву ты просто накопипастишь кучу
> строк, ничего страшного не произойдёт, никто с тебя смеяться не будет,
> не переживай.

вообще не парюсь.
по запаре, невнимательности или просто потому что по ошибке в голову пришло неверное решение, все пишут хрень. Иногда вообще достаточно просто СВЕЖЕГО взгляда - поспать и глянуть заново, или дать глянуть кому-то еще и ошибка будет видна.

Вот только беда - как-то этим заниматься скучновато, когда тебе всего-то нужен новый свежий драйвер nvidia, о котором ты прочитал на похорониксе только что.

Это чисто дестопная проблема, все равно, это более неочевидно, чем если бы те же версии софтин задавались, допустим, в конфиге (как сейчас пакеты) и вообще в целом оно было бы... ну почеловекообразнее что ли.

Не все супер умные линупcоиды, так же не все супер умные линупcоиды имеют свободное время пердолится с системой, вместо более высокооплачиваемой работы.


Ответить | Правка | Наверх | Cообщить модератору

85. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (85), 02-Дек-23, 19:07 
>[оверквотинг удален]
> - поспать и глянуть заново, или дать глянуть кому-то еще и
> ошибка будет видна.
> Вот только беда - как-то этим заниматься скучновато, когда тебе всего-то нужен
> новый свежий драйвер nvidia, о котором ты прочитал на похорониксе только
> что.
> Это чисто дестопная проблема, все равно, это более неочевидно, чем если бы
> те же версии софтин задавались, допустим, в конфиге (как сейчас пакеты)
> и вообще в целом оно было бы... ну почеловекообразнее что ли.
> Не все супер умные линупcоиды, так же не все супер умные линупcоиды
> имеют свободное время пердолится с системой, вместо более высокооплачиваемой работы.

Относительно свежие драйвера на видео будут в Fedora и в Debian testing, они по факту стабильнее и предсказуемее, чем Арчи всякие и его производные, но порог вхождения и охват аудитории у них выше, чем в NixOS.

Тут очень большой вопрос насчёт того, а назачем нужны эти новые драйвера? Для игр, для рендеринга чего-нибудь видяшного или же куды-шмуды всякие и для сурьёзного общёта?

В зависимости от задач тот или иной дистр будет готовее и менее запарнее другого, если рассматривать с точки зрения минимума телодвижений после установки. В некоторых ситуациях бывают даже готовые решения, изкоробочный, "под ключ".

Ответить | Правка | Наверх | Cообщить модератору

86. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (85), 02-Дек-23, 19:08 
>[оверквотинг удален]
> Относительно свежие драйвера на видео будут в Fedora и в Debian testing,
> они по факту стабильнее и предсказуемее, чем Арчи всякие и его
> производные, но порог вхождения и охват аудитории у них выше, чем
> в NixOS.
> Тут очень большой вопрос насчёт того, а назачем нужны эти новые драйвера?
> Для игр, для рендеринга чего-нибудь видяшного или же куды-шмуды всякие и
> для сурьёзного общёта?
> В зависимости от задач тот или иной дистр будет готовее и менее
> запарнее другого, если рассматривать с точки зрения минимума телодвижений после установки.
> В некоторых ситуациях бывают даже готовые решения, изкоробочный, "под ключ".

*порог входжения ниже, а охват аудитории ниже, чем в NixOS

Ответить | Правка | Наверх | Cообщить модератору

87. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (85), 02-Дек-23, 19:09 
>[оверквотинг удален]
>> Относительно свежие драйвера на видео будут в Fedora и в Debian testing,
>> они по факту стабильнее и предсказуемее, чем Арчи всякие и его
>> производные, но порог вхождения и охват аудитории у них выше, чем
>> в NixOS.
>> Тут очень большой вопрос насчёт того, а назачем нужны эти новые драйвера?
>> Для игр, для рендеринга чего-нибудь видяшного или же куды-шмуды всякие и
>> для сурьёзного общёта?
>> В зависимости от задач тот или иной дистр будет готовее и менее
>> запарнее другого, если рассматривать с точки зрения минимума телодвижений после установки.
>> В некоторых ситуациях бывают даже готовые решения, изкоробочный, "под ключ".

**порог входжения ниже, а охват аудитории больше, чем в NixOS

(пц, пора спать мне xD)

Ответить | Правка | Наверх | Cообщить модератору

91. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 03-Дек-23, 02:00 
Свежие драйвера на видео будут везде из .run файла. Ядро свежее собрать и опакетить тоже простое дело.

Для тех же игр, например, допустим есть баг или несовместимость с какой-то игрой из свежачка - их относительно оперативно фиксят, но оно может до nixpkgs долго доезжать, а у тебя, допустим, время на выходных только вот этих есть - и технически все готово везде, кроме дистра. Пердолинг будет несравнимо больше, чем с каким-нибудь deb или rpm дистром.

У изкоробочных решений под ключ есть одна проблема - как в той шутке про стрелка, который вокруг прилета стрел рисовал мишени - этот "ключ" для каждого свой и чаще всего проще взять какой-нибудь обычный дебиана или rhel и допилить его своими ансиблами вокруг древка стрелы, а не пробовать 10 тыщ дистров от васянов в надежде найти подходящий.

Вот тут с NixOS и выстреливает тот факт, что обслуживается она намного сложнее привычных дистров.
Это не то, что бы минус - но хотелось бы это как-то изменить, не знаю - сделать ее человекообразнее что ли, то ли документацией для плюшечек, булочек и совсем уж зачерствевших хлебушков, то ли злых корпоратов как-то запрячь решить аналогичную задачу.

В целом "свежак" в линуксе вообще не нужен и не является самоцелью в большинстве случаев, проблемой являются ситуации, когда нужен именно какой-то конкретный свежак.

Ответить | Правка | К родителю #85 | Наверх | Cообщить модератору

15. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от OpenEcho (?), 01-Дек-23, 04:21 
> Первые пару месяцув прикольно,

Именно... 6-ти месячый апгрэдинг цикл слишком короток для продакшен систем, не с проста красная шляпа и бубунта имеют LTS. И если что надо ставить проприетарное (продакшен однако) то можно долго веселиться с nix-ld и то не всегда успешно. Но из хорошего конечно так это - эксперементировать, удобно, хотя многое  можно решить с другими системами с помощью снэпшатов виртуалок

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

16. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 05:06 
Можешь не веселиться, а собирать под проприетарь FHS-загон. При должной сноровке, не отличит твою NixOS от Убунты или RHEL. Все нужные для этого механизмы в поставке. Правда, если софт дофига умный, то может не работать. Но тут уж ой.
Ответить | Правка | Наверх | Cообщить модератору

54. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Минона (ok), 01-Дек-23, 15:12 
Если проприетарь требует конкретную версию шляпы или убунты - надо ставить то что просят.
Зачем делать себе больно?
Ответить | Правка | Наверх | Cообщить модератору

74. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 19:15 
Ну раз требует, тогда ставь, что ж поделаешь? К счастью, мир не ограничивается капризными проприетарными программами.
Ответить | Правка | Наверх | Cообщить модератору

30. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Местный Эксперт (?), 01-Дек-23, 10:29 
> Ты им попользуйся и поймешь. Первые пару месяцув прикольно, но потом тебе
> внезапно надо собрать сторонний пакет руками и начинаются пляски с бубном.
> Решение интересное для "встроенных" систем с простым откатом обновлений.

А контейнейр для этого внезапно стороннего пакета никак нельзя применить? Флатпаки, снапы, сорта вот этого, не?
И потом, что это за кpacнoглaзый такой пользователь NixOS, который не может запушить нужный ему пакет в канал?!

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

22. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (22), 01-Дек-23, 08:23 
>Ванную что сабж вытиснит все остальные дистры.

Уже 21 год вытесняет, да все никак не вытеснит.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

49. Скрыто модератором  +/
Сообщение от Анонимусс (?), 01-Дек-23, 14:38 
Ответить | Правка | Наверх | Cообщить модератору

57. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от Вася (??), 01-Дек-23, 15:55 
>>Ванную что сабж вытиснит все остальные дистры.
> Уже 21 год вытесняет, да все никак не вытеснит.

он только несколько лет последних стал более-менее годным.

Ответить | Правка | К родителю #22 | Наверх | Cообщить модератору

23. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от 1 (??), 01-Дек-23, 09:21 
Повангуй на тему rc.conf из BSD систем.
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

72. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (72), 01-Дек-23, 17:45 
Нет ну FreeBSD на голову лучше этого вашего линукса, я и не спорю.
Ответить | Правка | Наверх | Cообщить модератору

26. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +4 +/
Сообщение от Аноним (26), 01-Дек-23, 09:53 
>>вся настройка системы происходит посредством единого файла системной конфигурации (configuration.nix),
> Вот это я понимаю уникальное торговое предложение (УТП).
> Ванную что сабж вытиснит все остальные дистры.

Не вытеснит, хотя УТП действительно крутое и не потому что единый файл конфигурации.
Тренд на то, что в мейнстриме всё вытеснят гуано-атомарки в стиле ubuntu-core, fedora silverblue и прочие подобные аналоги от разных производителей и это печально, потому что на фоне NixOS это слоупочные прибитые гвоздями и огороженные жирносборки на костылях.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

58. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 15:56 
> Тренд на то, что в мейнстриме всё вытеснят гуано-атомарки в стиле ubuntu-core,
> fedora silverblue и прочие подобные аналоги от разных производителей и это
> печально

с чего вдруг, если они друг-друга то не могут вытеснить?

Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (3), 30-Ноя-23, 22:52 
> При использовании Nix результат сборки пакетов хранится в отдельной поддиректории в /nix/store. Например, после сборки пакет firefox может записываться в /nix/store/1onlv6pc3ed4n5nskg8ew4twcfd0d5ce4ec5d4-firefox-120.0.1/, где "1onlv6pc3ed4n5nskg8ew4twcfd0d5ce4ec5d4" является хешем всех его зависимостей и инструкций сборки.

Интересно как пользователи обычных дистров всю жизнь нормально живут без этого.

Ответить | Правка | Наверх | Cообщить модератору

5. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +3 +/
Сообщение от Аноним (1), 30-Ноя-23, 22:56 
Большую часть времени неплохо, но иногда сильно мучаются, когда, к примеру, разваливается всё при неудачном обновлении. Или когда софт требует либу одной версии, а в системе стоит совершенно другая, несовместимая. Все эти проблемы, конечно же, можно легко решить, но с Nix их решать не надо, что большой плюс для тех, у кого больше дюжины серверов.
Ответить | Правка | Наверх | Cообщить модератору

59. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 15:58 
> Большую часть времени неплохо, но иногда сильно мучаются, когда, к примеру, разваливается
> всё при неудачном обновлении. Или когда софт требует либу одной версии,
> а в системе стоит совершенно другая, несовместимая. Все эти проблемы, конечно
> же, можно легко решить, но с Nix их решать не надо,
> что большой плюс для тех, у кого больше дюжины серверов.

вот у тебя сраные 13 сервервов (это вообще ниачом)
тебе вдруг резко надо что-то сделать в них, что тривиально в обычном дистре и ты без понятия как это сделать в никсе.
Что проще, починить проблему зависимостей у одной софтины (которая в LTS случае и не появится скорее всего) или же пердолиться с configuration.nix часами в попытках завести то, что у тебя не работает?

Ответить | Правка | Наверх | Cообщить модератору

75. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 19:27 
Я не знаю, что тебе проще. У меня и с NixOS проблем нет, и с дебианоидами, и с редхатоидами, и даже с редко встречающимися в наше вермя ОС из прошлого века. За столько лет «в траншеях» уже без разницы в общем-то какая там операционная система, лишь бы на команды реагировала и хоть какая-то документация была. Когда надо с нуля что-то строить, в первую очередь беру NixOS именно потому, что не надо часами «пердолиться» с configuration.nix и зависимости чинить. Софт либо собрался и работает, либо не собрался и не работает. Без промежуточных состояний типа «вчера всё работало, а ночью OpenSSL обновился».
Ответить | Правка | Наверх | Cообщить модератору

82. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 02-Дек-23, 12:25 
> Я не знаю, что тебе проще. У меня и с NixOS проблем
> нет, и с дебианоидами, и с редхатоидами, и даже с редко
> встречающимися в наше вермя ОС из прошлого века. За столько лет
> «в траншеях» уже без разницы в общем-то какая там операционная система,
> лишь бы на команды реагировала и хоть какая-то документация была. Когда
> надо с нуля что-то строить, в первую очередь беру NixOS именно
> потому, что не надо часами «пердолиться» с configuration.nix и зависимости чинить.
> Софт либо собрался и работает, либо не собрался и не работает.
> Без промежуточных состояний типа «вчера всё работало, а ночью OpenSSL обновился».

а теперь объясни Пете как срочно починить твой nixos, который сломался или требует какого-то срочного апдейта в проде, потому что ты сам уехал на недельку отдыхать подальше от этой вашей техники, если, конечно, для тебя это актуально все и ты не живешь в подвале

Ответить | Правка | Наверх | Cообщить модератору

88. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (85), 02-Дек-23, 19:12 
>[оверквотинг удален]
>> «в траншеях» уже без разницы в общем-то какая там операционная система,
>> лишь бы на команды реагировала и хоть какая-то документация была. Когда
>> надо с нуля что-то строить, в первую очередь беру NixOS именно
>> потому, что не надо часами «пердолиться» с configuration.nix и зависимости чинить.
>> Софт либо собрался и работает, либо не собрался и не работает.
>> Без промежуточных состояний типа «вчера всё работало, а ночью OpenSSL обновился».
> а теперь объясни Пете как срочно починить твой nixos, который сломался или
> требует какого-то срочного апдейта в проде, потому что ты сам уехал
> на недельку отдыхать подальше от этой вашей техники, если, конечно, для
> тебя это актуально все и ты не живешь в подвале

А это не баг, а фича, такой вот вендорлокинг, точнее админолокинг, нефиг всяким Петям иметь шанс подсидеть и заменить нашего доблестного админа! xD

Ответить | Правка | Наверх | Cообщить модератору

89. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 02-Дек-23, 19:24 
> А это не баг, а фича, такой вот вендорлокинг, точнее админолокинг, нефиг
> всяким Петям иметь шанс подсидеть и заменить нашего доблестного админа! xD

так себе фича - работать-то кому-то надо, хорошо все уметь, но не дай боже все делать самому

Ответить | Правка | Наверх | Cообщить модератору

95. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 04-Дек-23, 05:25 
> а теперь объясни Пете

Пете может и не смогу объяснить, я с ним не знаком. А вот Йохан (программист на Хаскеле, человек довольно далёкий от системного администрирования) въехал во все важные аспекты их системы за две недели. То было два года назад. С тех пор они там ещё двух админов наняли дальше развивать то, что я начал. Йохан писал, что один сразу Nix знал, а второго сообща научили по быстрому. Хорошо, конечно, что не я один в мире с Nix разобрался, а то и вправду беда была бы.

Ответить | Правка | К родителю #82 | Наверх | Cообщить модератору

96. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 04-Дек-23, 17:45 
>> а теперь объясни Пете
> Пете может и не смогу объяснить, я с ним не знаком. А
> вот Йохан (программист на Хаскеле, человек довольно далёкий от системного администрирования)
> въехал во все важные аспекты их системы за две недели. То
> было два года назад. С тех пор они там ещё двух
> админов наняли дальше развивать то, что я начал. Йохан писал, что
> один сразу Nix знал, а второго сообща научили по быстрому. Хорошо,
> конечно, что не я один в мире с Nix разобрался, а
> то и вправду беда была бы.

угу и теперь за две недели он может сделать все что угодно, ага, верю, верим, я поверив
система часто требует НЕСТАНДАРТНЫХ действий. Если у тебя клиент бьет копытом и нужно починить за 10 минут то, что в обычном дистре делается за одну команду, а в nixos падает с сегментейшен фолтом или еще что-то подобное - разбираться ты будешь гарантированно дольше чем в обычном линуксе

Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +3 +/
Сообщение от Аноним (11), 30-Ноя-23, 23:37 
Пользователи обычных дистров имеют те версии программ, которые им поставил Господин. Если нужна версия посвежее или постарее, то нужно Превозмогать, Терпеть или скачивать Нескучные Велосипеды. Например, если нужен Node.js определенной версии, то пользуешься такой штукой, как nvm — "скачиватель Node.js определенной версии". Ну не бред ли? А в NixOS такая проблема решена как класс.
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

60. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 16:01 
> Пользователи обычных дистров имеют те версии программ, которые им поставил Господин. Если
> нужна версия посвежее или постарее, то нужно Превозмогать, Терпеть или скачивать
> Нескучные Велосипеды. Например, если нужен Node.js определенной версии, то пользуешься
> такой штукой, как nvm — "скачиватель Node.js определенной версии". Ну не
> бред ли? А в NixOS такая проблема решена как класс.

ценой необходимости вкладываться в решение проблем, конечно же.
Если оно не опкачено - иди опакечивай. Ой, что, не знаешь как? Почитай документацию! Ой, а что, документации нет? Ну почитай исходники. Ой, что, не знаешь Nix? Бедняжка! иди учи!

И кто после этого страдает, юзер никсоси или юзер nvm?

Ответить | Правка | Наверх | Cообщить модератору

27. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (26), 01-Дек-23, 09:53 
>> При использовании Nix результат сборки пакетов хранится в отдельной поддиректории в /nix/store. Например, после сборки пакет firefox может записываться в /nix/store/1onlv6pc3ed4n5nskg8ew4twcfd0d5ce4ec5d4-firefox-120.0.1/, где "1onlv6pc3ed4n5nskg8ew4twcfd0d5ce4ec5d4" является хешем всех его зависимостей и инструкций сборки.
> Интересно как пользователи обычных дистров всю жизнь нормально живут без этого.

Просто не знают, что они живут в гуане, как это обычно по жизни бывает. xD

Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

41. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Аноним (41), 01-Дек-23, 13:03 
Ну как-как... Пока сидят и юзают тот софт, который им подсунули авторы дистриба и мейнтейнеры реп этого дистриба (в режиме "ты тут ничего не трогай, а то сломаешь" короче), то более-менее нормально.
Но вот когда оказывается, что пользователю захотелось иметь 2 проги, обе из которых хотят одну и ту же либу, но каждая из хочет её определенную версию, не ту, что хочет вторая - начинается краcнозенковый пердолинг.
Или когда (в чём-то это вариация предыдущего) софтина хочет либу одной версий, а у тебя в системе эта либа другой версии. А вот прога белугой воет, что ей надо старее/новее.
Или когда юзер хочет иметь и запускать несколько разных версий одной и той же проги. Браузера какого, например. Или одной версии, но собранной с разными флагами.
Бизнес вон эти тупые пердолинги так достали как-то, что для того, чтобы не пердолиться начали придумывать себе всякие там докинги, а потом потянулось нивеляция этого пердолинга и для домашних юзеров в виде всяких там флатпаков, снапов, аппимэйджей. Всё ради того, чтобы не пердолиться (с зависимостями, конфликтами зависимостей, дистрибузависимостью и вот этим всем).
Ответить | Правка | К родителю #4 | Наверх | Cообщить модератору

8. Скрыто модератором  +6 +/
Сообщение от TrollGPT (?), 30-Ноя-23, 23:31 
Ответить | Правка | Наверх | Cообщить модератору

24. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от worldmind (?), 01-Дек-23, 09:44 
При таком подходе я бы ожидал роллинг со всеми наисвежайшими версиями
Ответить | Правка | Наверх | Cообщить модератору

28. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  –1 +/
Сообщение от Местный Эксперт (?), 01-Дек-23, 09:56 
> При таком подходе я бы ожидал роллинг со всеми наисвежайшими версиями

А по факту там версии пакетов не свежее федоркиных или гентушных. NixOS это не про самый свежий свежак, это про гибкость и лёгкость перестроений системы в несколько кликов "туда и обратно".

Ответить | Правка | Наверх | Cообщить модератору

55. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Минона (ok), 01-Дек-23, 15:28 
Там уже можно "кликать" вместо ручного пердолинга с .nix файлами?
Ответить | Правка | Наверх | Cообщить модератору

80. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (80), 02-Дек-23, 00:29 
> Там уже можно "кликать" вместо ручного пердолинга с .nix файлами?

В любом дистре можно кликать, даже в самом бедном на GUI-обёртки над православными консольными тулзами.
Всё это становиться неважным, как только хоть самую малость на базовом уровне познаёшь магию баша! xD

Ответить | Правка | Наверх | Cообщить модератору

35. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от Аноним (33), 01-Дек-23, 11:07 
Кому нужен роллинг, те сидят на nixos-unstable и получают свежак (почти) каждый день. Автоматические интеграционные тесты, без прохода которых канал nixos-unstable не обновляется, дают хоть какие-то гарантии, что после обновления система хотя бы загрузится, в отличии от других дистрибутивов где такого тестирования нет, либо оно ручное. Если же проблемы с загрузкой всё же вылезут (например, в ядре что-то намудили конкретно с твоей железкой) - можно загрузиться в предыдущую версию выбрав её в загрузчике.
Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

45. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от Аноним (45), 01-Дек-23, 14:00 
Более того, stable и unstable еще и миксовать можно без риска что-то поломать.
Ответить | Правка | Наверх | Cообщить модератору

56. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Минона (ok), 01-Дек-23, 15:33 
> Если же проблемы с загрузкой всё же вылезут (например, в ядре что-то намудили конкретно с твоей железкой) - можно загрузиться в предыдущую версию выбрав её в загрузчике.

Дистры на OSTree так тоже умеют.

Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

66. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Я в курсе а ты (?), 01-Дек-23, 17:04 
>> Если же проблемы с загрузкой всё же вылезут (например, в ядре что-то намудили конкретно с твоей железкой) - можно загрузиться в предыдущую версию выбрав её в загрузчике.
> Дистры на OSTree так тоже умеют.

Да, только они тупее и медленнее, не такие гибкие. И потом, никсось не в теории, а на практике имеет штатную изкоробочную возможность откатов до любого прошлого состояния, тогда как та же silverblue например этим похвастаться не может.

Не знаю как там устроено в аналогичном проекта openSUSE, но те же атомарные федорки с их rpm-ostree заставляют перезагружаться, чтобы начать пользоваться, установленными через rpm-ostree, пакетами. Тогда как в NixOS можно ими пользоваться сразу и разработчики системы не полагаются на внешние блоатварные костыли, типа флатпаков.

Ответить | Правка | Наверх | Cообщить модератору

64. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Местный экспертный эксперт (?), 01-Дек-23, 16:56 
> Кому нужен роллинг, те сидят на nixos-unstable и получают свежак (почти) каждый
> день. Автоматические интеграционные тесты, без прохода которых канал nixos-unstable не
> обновляется, дают хоть какие-то гарантии, что после обновления система хотя бы
> загрузится, в отличии от других дистрибутивов где такого тестирования нет, либо
> оно ручное. Если же проблемы с загрузкой всё же вылезут (например,
> в ядре что-то намудили конкретно с твоей железкой) - можно загрузиться
> в предыдущую версию выбрав её в загрузчике.

Вот только не надо тут про астрейбл никсоса и свежак, ага.
По факту это просто такой более стабильный рачик, но с гибкостью больше напоминающую гентушную, если грубо, только с более удобным управлением всего этого цирка. Нет там такого уж лютого свежака, а вот анстейбл местами есть, причём не только в ветке анстейбл, но это избержки того, что всё что можно и нельзя собирается на автомате и живых рук не хватает всякие косяки молниеносно править.

В целом это хороший дистр, как замена всякого иммутабельного шлака, которые сейчас двигают, он гораздо быстрее и гибче конфигурируется и перестраивается, но это не замена продакшон-дитсрам, которые "поставил и забил на 10 лет".

Ответить | Правка | К родителю #35 | Наверх | Cообщить модератору

61. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Вася (??), 01-Дек-23, 16:04 
> При таком подходе я бы ожидал роллинг со всеми наисвежайшими версиями

там на unstable считай и есть rolling

Ответить | Правка | К родителю #24 | Наверх | Cообщить модератору

25. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +2 +/
Сообщение от Аноним (26), 01-Дек-23, 09:48 
> "обеспечены воспроизводимые сборки"

То есть в NixOS имея нужный конфигурационный файл, можно собрать 1 в 1 систему, которую положим собирали три года назад, так получается?
О какого рода воспроизводимости вообще идёт речь?

Ответить | Правка | Наверх | Cообщить модератору

29. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от Аноним (29), 01-Дек-23, 10:09 
Да, только если прям один в один хочешь, то файлов нужно больше, чем один. Но имхо это оверкилл для 99.9% задач, особенно если учесть, что там встречаются косяки, у меня, например, не получилось завести кде с драйверами виедокарты, по какой-то причине работает только гном.
Ответить | Правка | Наверх | Cообщить модератору

32. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (32), 01-Дек-23, 10:40 
> Да, только если прям один в один хочешь, то файлов нужно больше,
> чем один. Но имхо это оверкилл для 99.9% задач, особенно если
> учесть, что там встречаются косяки, у меня, например, не получилось завести
> кде с драйверами виедокарты, по какой-то причине работает только гном.

Не, я именно про вариант 1 к 1 одинаковую систему, если мне например нужно воспроизводимую среду собрать из 20го года, у NixOS есть какой-то архив таких пакетов, каналов, чтобы это всё можно было провернуть?

Если речь про проблемы старых версий драйверов на новом железе, оно и понятно, если речь о чём-то другом, то требуется пояснительная бригада!

Ответить | Правка | Наверх | Cообщить модератору

36. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (33), 01-Дек-23, 11:12 
Можешь запинить нужный коммит nixpkgs и будет тебе везде одинаковая система
Ответить | Правка | Наверх | Cообщить модератору

37. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (29), 01-Дек-23, 11:31 
Сильно не углубялся, но у них есть lock файлы для пакетов, называются flakes, и я так понял да, у них хранятся в каком-то виде архивные версии
Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

47. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (41), 01-Дек-23, 14:25 
Есть техническая гарантия, что при наличии всех тех же файлов ты сможешь собрать один-водин такой же результат. Гарантии, что для тебя (_вместо тебя_) кто-то все эти файлы будет хранить _вечно_ - нет. Но это не технический вопрос.
Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

67. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (67), 01-Дек-23, 17:06 
> Есть техническая гарантия, что при наличии всех тех же файлов ты сможешь
> собрать один-водин такой же результат. Гарантии, что для тебя (_вместо тебя_)
> кто-то все эти файлы будет хранить _вечно_ - нет. Но это
> не технический вопрос.

Вопрос был про скорее про то, как с этим вопросом дела по факту обстоят? ;)

Ответить | Правка | Наверх | Cообщить модератору

97. Скрыто модератором  +/
Сообщение от morphe (?), 05-Дек-23, 15:24 
Ответить | Правка | Наверх | Cообщить модератору

76. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 19:43 
Да, можно, но с некоторыми оговорками. В общем случае, собранный при помощи Nix софт всегда собирается одинаково, с точностью до хэша. Однако, иногда софт при сборке использует невоспроизводимые параметры. Например, текущее время на сборочном хосте. В Nix проделано много работы, чтобы даже такой софт собирался повторяемо, но всего не предусмотришь и косяки иногда вылазят, а что-то и вовсе можно починить только патчами в апстрим. Большого вреда от этого нет, на практике — если мы говорим не о локалхосте — сборка осуществляется централизовано, и результат потом раскидывается по хостам. Но знать о таком поведении, наверное, нужно. Что касается воспроизведения сборки NixOS «из 20го года», для этого нужно найти подходящий тебе по дате коммит в nixpkgs, явно указать на него штатными средствами Nix и собрать. Если исходники всё ещё доступны (через интернет или у тебя есть свои архивы, которые ты штатными утилитами добавишь в /nix/store), ты получишь сборку NixOS, актуальную для того времени, 1 к 1, с учётом сказанного выше.
Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

81. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (81), 02-Дек-23, 00:36 
>[оверквотинг удален]
> и вовсе можно починить только патчами в апстрим. Большого вреда от
> этого нет, на практике — если мы говорим не о локалхосте
> — сборка осуществляется централизовано, и результат потом раскидывается по хостам.
> Но знать о таком поведении, наверное, нужно. Что касается воспроизведения сборки
> NixOS «из 20го года», для этого нужно найти подходящий тебе по
> дате коммит в nixpkgs, явно указать на него штатными средствами Nix
> и собрать. Если исходники всё ещё доступны (через интернет или у
> тебя есть свои архивы, которые ты штатными утилитами добавишь в /nix/store),
> ты получишь сборку NixOS, актуальную для того времени, 1 к 1,
> с учётом сказанного выше.

Спасибо за развёрнутый ответ!
Однако, я интересовался скорее не о теоретической технической возможностью этой стороны вопроса, а о больше практической стороной. Насколько это осуществимо на практике.

Меня именно интересует скорее доступность этих самых архивных "срезов" каналов, чтобы они были постоянно в доступе.
Или же на практике это всё быстро протухает, вычищается/выкидывается на мороз как "нинужное"?!

Ответить | Правка | Наверх | Cообщить модератору

93. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (93), 03-Дек-23, 11:02 
Нет, nixpkgs лежит на github и его код лежит весь с 2004 года полностью.
cache.nixos.org вроде тоже с самых первых версий кеш хранит, около 300тб уже.
Ответить | Правка | Наверх | Cообщить модератору

94. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (94), 04-Дек-23, 01:32 
> Нет, nixpkgs лежит на github и его код лежит весь с 2004
> года полностью.
> cache.nixos.org вроде тоже с самых первых версий кеш хранит, около 300тб уже.

Спасибо вам за ответ, это вселяет надежду, если так! :)

Ответить | Правка | Наверх | Cообщить модератору

34. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +3 +/
Сообщение от Аноним (34), 01-Дек-23, 11:05 
> есть возможность одновременного использования нескольких версий одной программы

Ничего себе. А я думал, так только винда может начиная с 80-ых годов.

Ответить | Правка | Наверх | Cообщить модератору

38. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (29), 01-Дек-23, 11:32 
Ну щас эту возможность даже ненавидимые всеми снапы дают, так что лет через 5 линукс в этом плане догонит венду
Ответить | Правка | Наверх | Cообщить модератору

51. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от Пряник (?), 01-Дек-23, 15:04 
Так как это делает NixOS - нет.
Ответить | Правка | К родителю #34 | Наверх | Cообщить модератору

40. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (-), 01-Дек-23, 12:30 
>Размер полного установочного образа с KDE 2.5 ГБ, GNOME - 2.4 ГБ

Это атомарно обновляемый дистр, поэтому дополнительно надо указывать месячный трафик обновлений. И наплохо бы, по критерию объёмности интернет трафика сравнивать с Генту.

Ответить | Правка | Наверх | Cообщить модератору

42. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (41), 01-Дек-23, 13:12 
> Это атомарно обновляемый дистр, поэтому дополнительно надо указывать месячный трафик обновлений.

Всмысле, ты хочешь уже сейчас знать сколько софтин обновят их авторы в следующем месяце и какой совокупный размер у них будет? Сорян, штатные предсказатели будущего в отпуске.
Тем более это напрямую от тебя зависит, как часто ты будешь обновлять софт - можешь месяц не апдейтить пакеты и будет 0.

Ответить | Правка | Наверх | Cообщить модератору

46. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (33), 01-Дек-23, 14:00 
> Это атомарно обновляемый дистр

Он-то атомарно обновляемый, но там не используются образы а-ля OSTree. Если в репе обновится к примеру докер, то при обновлении оно скачает только этот самый докер. Если изменения более глубокие, например glibc, то тогда да, нужно будет скачать всё.

> И наплохо бы, по критерию объёмности интернет трафика сравнивать с Генту.

Если не использовать бинарные кеши и собирать всё из исходников а-ля генту, то трафик будет +- такой же как и у генту (скачать новую версию nixpkgs + новые исходники). Здесь уж что важнее, трафик или потраченное на сборку время и электричество

Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

52. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Пряник (?), 01-Дек-23, 15:06 
> Если изменения более глубокие, например glibc, то тогда да, нужно будет скачать всё.

Только libc. Остальное - пересобрать.

Ответить | Правка | Наверх | Cообщить модератору

68. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Требуется пояснительная бригада (?), 01-Дек-23, 17:09 
>>Размер полного установочного образа с KDE 2.5 ГБ, GNOME - 2.4 ГБ
> Это атомарно обновляемый дистр, поэтому дополнительно надо указывать месячный трафик обновлений.
> И наплохо бы, по критерию объёмности интернет трафика сравнивать с Генту.

Вы можете пояснить, что вы вкладываете в понятие, "атомарно обновляемый дистр" в данном контексте.
А то, с некоторых точек зрения, как ни крути, то неделимой системой, без разделение на пакеты её не назвать, а если топить за то, что обновляется она только целиком как правило, то тогда и рачик тоже в таком случае атомарный дистр!

Ответить | Правка | К родителю #40 | Наверх | Cообщить модератору

48. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  –1 +/
Сообщение от Аноним (48), 01-Дек-23, 14:29 
Guixsd хах. А это для хипстеров.
Ответить | Правка | Наверх | Cообщить модератору

69. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +1 +/
Сообщение от yomama (?), 01-Дек-23, 17:10 
> Guixsd хах. А это для хипстеров.

Guix давно без sd, чтоб ты знал, так что кто ещё хипстор?! ))

Ответить | Правка | Наверх | Cообщить модератору

53. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Анонимщик (?), 01-Дек-23, 15:11 
Каждый раз правка конфигов nix-а вызывает стойкое желание уйти в запой. Хаскель как основа языка для файла конфигурации - это очень полезно для предотвращения деменции, но как какой-нибудь рабоче-крестьянский ямль был бы тоже неплох.
Ответить | Правка | Наверх | Cообщить модератору

65. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (33), 01-Дек-23, 16:57 
Там хаскелем и не пахнет, это скорее вариация на json/toml только с функциями. Сразу видно человека, который ни nix, ни хаскель толком-то и не видел
Ответить | Правка | Наверх | Cообщить модератору

70. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Нубасий (?), 01-Дек-23, 17:13 
> Каждый раз правка конфигов nix-а вызывает стойкое желание уйти в запой. Хаскель
> как основа языка для файла конфигурации - это очень полезно для
> предотвращения деменции, но как какой-нибудь рабоче-крестьянский ямль был бы тоже неплох.

Чел, я не знаю о каком хаскеле ты ведёшь речь, но я даже будучи полным нубом в этом деле, просто посмотрел гайд как это делать и поставил себе обычный свой радовой десктоп.
Не скажу, что сразу понял логику некоторых моментов и что с ней согласен, но тем не менее, я даже официальных мануалов тогда не открывал и ни одной портянки текста по этому поводу не прочёл, а систему смог поставить по гайду для мамкиных кpacнoглaзиков. Это к вопросу о том, насколько это сложно сделать. Как по мне, с рачем и тем более гентой пердолинга больше при установке и отладке.

Ответить | Правка | К родителю #53 | Наверх | Cообщить модератору

77. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (1), 01-Дек-23, 19:53 
> какой-нибудь рабоче-крестьянский ямль был бы тоже неплох

Для таких вещей в Nix есть fromTOML и fromJSON. У меня так GUI для девелоперов работает. Можно брямо в браузере накликать зависимостей и получить сконфигурированный репозиторий с окружением разработчика. В 80% случаев работает без дополнительной ручной обработки, а для оставшихся 20% так или иначе нужен человек чтобы принять решение. И нет, там не Хаскель. Но Nix весьма популярен среди хаскелистов, да.

Ответить | Правка | К родителю #53 | Наверх | Cообщить модератору

78. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (78), 01-Дек-23, 20:55 
Никс так жарко описывают, что поставил и разочаровался. Имея прям вот тут calculate-linux вылизанный, отполированный, в том числе и юридически, бегать за тридевять земель шилом патоку хлебать, кмк перебор. Не нашёл причин, ни одной. Ну сделай на ансибле один файл и ставь так же, но без 37000 мягких ссылок. timemachine на ссылках через rsync сделать и в 12 году можно было, и не скажу что сложно. Интересный проект, но вау-эффекта других анонимов я не словил, вообще не торкнуло.
Ответить | Правка | Наверх | Cообщить модератору

79. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  +/
Сообщение от Аноним (79), 02-Дек-23, 00:20 
> Никс так жарко описывают, что поставил и разочаровался. Имея прям вот тут
> calculate-linux вылизанный, отполированный, в том числе и юридически, бегать за тридевять
> земель шилом патоку хлебать, кмк перебор. Не нашёл причин, ни одной.
> Ну сделай на ансибле один файл и ставь так же, но
> без 37000 мягких ссылок. timemachine на ссылках через rsync сделать и
> в 12 году можно было, и не скажу что сложно. Интересный
> проект, но вау-эффекта других анонимов я не словил, вообще не торкнуло.

Calculate ваш жирный и медленный при перестроениях, я им пользовался одно время. Со скоростью установки софта и перестроения системы и рядом не стоял. Также, если не жить 100% на бинхостах, которые причём могут быть всё же разные, то у каждого ещё будут и свои вариации сборки пакетов. 100% гарантий повторимости системы из-за этого нет, т.к. это не задумывалось изначально. Даже если этого и можно добиться в теории, это шибко геморройно, а на практике никто в здравом уме даже source-based систему для нужд повторимости окружения не будет рассматривать.

У NixOS же кроме скорости изменения и перестроения системы, отличной в лучшую сторону относительно гентушных, ещё и заложенная архитектурно повторимость сборки.

Я понимаю тех, кто сидит на Gentoo и даже отчасти могу понять тех, кто сидит на Calculate, если их всё устраивает, то пожалуйста. Но на серьёзных щах сравнивать эти системы как минимум странно, они вообще по-разному решают неодинаковые задачи, хотя согласен, некоторые из этих задач пересекаются. И в моменте пересечения зачастую Gentoo чисто по простоте и удобству, по скорости работы настройки и перестроения проигрывает. Хотя признаю, даже у Gentoo есть сильные стороны, которых пока в такой форме нигде не реализовано, хотя возможно я просто не знаю альтернатив.

Ответить | Правка | Наверх | Cообщить модератору

92. "Выпуск дистрибутива NixOS 23.11, использующего пакетный мене..."  –3 +/
Сообщение от ИмяХ (ok), 03-Дек-23, 08:49 
>>вся настройка системы происходит посредством единого файла системной конфигурации (configuration.nix)

Это уже давно есть в виндовсе, называется реестр.

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру