!
interface GigabitEthernet0/1
description ## 100 Mbp/s ##
ip address 192.168.44.226 255.255.255.252
ip access-group 138 in
ip accounting output-packets
ip nat outside
ip route-cache flow
ip policy route-map MAP
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3.332
description ## 200 Mbit/s ##
encapsulation dot1Q 332
ip address 192.111.97.146 255.255.255.252
ip nat outside
no snmp trap link-status
!
ip nat pool ISP2-pool 192.111.101.128 192.111.101.191 prefix-length 26
ip nat pool ISP1-pool 192.221.39.0 192.221.39.255 prefix-length 24
ip nat pool ISP1_2-pool 192.67.49.0 192.67.49.255 prefix-length 24
ip nat inside source list 19 interface GigabitEthernet0/1 overload
ip nat inside source route-map ISP2-NAT pool ISP2-pool overload
ip nat inside source route-map ISP1-NAT pool ISP12-pool overload
ip nat inside source route-map ISP1_2-NAT pool ISP1-pool overloadroute-map ISP2-NAT permit 10
match ip address 1
match interface GigabitEthernet0/3.332
!
route-map ISP deny 10
match ip address 100
!
route-map ISP permit 20
match ip address 1
set ip next-hop 192.168.44.225
!
route-map ISP permit 30
match ip address 2
set ip next-hop 192.111.97.145
!
route-map ISP1-NAT permit 10
match ip address 2
match interface GigabitEthernet0/1