Добрый день.
Задача довольно простая, но все никак не могу понять, почему не работает.
Имеется 2 циски 1841 : Cisco IOS Software, 1841 Software (C1841-ENTSERVICES-M), Version 12.4(12), RELEASE SOFTWARE (fc1)
--------------------------------
Дано:
3 канала связи (одинаковая полоса):
VL10 - 192.168.10.0/30 (R1-R2)
VL20 - 192.168.20.0/30 (R1-R2)
VL30 - 192.168.30.0/30 (R1-R2)
VL100 - сеть USER1 (на R2) 10.10.10.0/24
VL200 - сеть USER2 (на R2) 20.20.20.0/24
VL200 - сеть USER3 (на R2) 30.30.30.0/24
сеть SERVER (на R1) 100.100.100.0/24 R1
/ | \
| | |
\ | /
R2
Одна автономная система: AS 100
----------------
Задача: необходимо с R2 анонсировать сеть USER1 по VL10, сеть USER2 по VL20, сеть USER3 по VL30 (с возможностью резервирования). Обратный трафик для R2 пусть идет по какому-то одному.
Примечание: R1 - минимум настроек, руление сетями, фильтрация и т.п. должно происходить на R2. Анонс default с R1 - обязательно.
----------------
Решение:
Конфиг R1:
interface FastEthernet0/0
description SERVER
ip address 100.100.100.1 255.255.255.0
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
description Tag_port_1
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.10
description CH-1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.20
description CH-2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.30
description CH-3
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
router bgp 100
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 192.168.10.2 remote-as 100
neighbor 192.168.10.2 default-originate
neighbor 192.168.20.2 remote-as 100
neighbor 192.168.20.2 default-originate
neighbor 192.168.30.2 remote-as 100
neighbor 192.168.30.2 default-originate
no auto-summary
!
ip route 100.100.100.0 255.255.255.0 Null0
R1#sh ip bgp
BGP table version is 31, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i10.10.10.0/24 192.168.10.2 0 150 0 i
* i 192.168.20.2 0 100 0 i
* i 192.168.30.2 0 100 0 i
* i20.20.20.0/24 192.168.10.2 0 100 0 i
*>i 192.168.20.2 0 150 0 i
* i 192.168.30.2 0 100 0 i
* i30.30.30.0/24 192.168.10.2 0 100 0 i
* i 192.168.20.2 0 100 0 i
*>i 192.168.30.2 0 150 0 i
R1#
---------как бы все отлично--------
Конфиг R2:
interface FastEthernet0/0
description USERs
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/0.100
description User-1
encapsulation dot1Q 100
ip address 10.10.10.1 255.255.255.0
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
interface FastEthernet0/0.200
description User-2
encapsulation dot1Q 200
ip address 20.20.20.1 255.255.255.0
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
interface FastEthernet0/0.300
description User-3
encapsulation dot1Q 300
ip address 30.30.30.1 255.255.255.0
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
no cdp enable
!
interface FastEthernet0/1
description Tag_port_1
no ip address
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1.10
description CH-1
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.20
description CH-2
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
interface FastEthernet0/1.30
description CH-3
encapsulation dot1Q 30
ip address 192.168.30.2 255.255.255.252
ip verify unicast reverse-path allow-self-ping
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
traffic-shape rate 256000 7936 7936 1000
no cdp enable
!
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 20.20.20.0 mask 255.255.255.0
network 30.30.30.0 mask 255.255.255.0
neighbor 192.168.10.1 remote-as 100
neighbor 192.168.10.1 route-map CH-1 out
neighbor 192.168.20.1 remote-as 100
neighbor 192.168.20.1 route-map CH-2 out
neighbor 192.168.30.1 remote-as 100
neighbor 192.168.30.1 route-map CH-3 out
no auto-summary
!
ip route 10.10.10.0 255.255.255.0 Null0
ip route 20.20.20.0 255.255.255.0 Null0
ip route 30.30.30.0 255.255.255.0 Null0
!
!
access-list 10 permit 10.10.10.0 0.0.0.255
access-list 10 deny any
access-list 11 permit 20.20.20.0 0.0.0.255
access-list 11 permit 30.30.30.0 0.0.0.255
access-list 11 deny any
access-list 20 permit 20.20.20.0 0.0.0.255
access-list 20 deny any
access-list 22 permit 10.10.10.0 0.0.0.255
access-list 22 permit 30.30.30.0 0.0.0.255
access-list 22 deny any
access-list 30 permit 30.30.30.0 0.0.0.255
access-list 30 deny any
access-list 33 permit 20.20.20.0 0.0.0.255
access-list 33 permit 10.10.10.0 0.0.0.255
access-list 33 deny any
route-map CH-2 permit 10
match ip address 20
set local-preference 150
!
route-map CH-2 permit 20
match ip address 22
set local-preference 100
!
route-map CH-3 permit 10
match ip address 30
set local-preference 150
!
route-map CH-3 permit 20
match ip address 33
set local-preference 100
!
route-map CH-1 permit 10
match ip address 10
set local-preference 150
!
route-map CH-1 permit 20
match ip address 11
set local-preference 100
!
R2#sh ip bgp
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i0.0.0.0 192.168.10.1 0 100 0 i
* i 192.168.20.1 0 100 0 i
* i 192.168.30.1 0 100 0 i
*> 10.10.10.0/24 0.0.0.0 0 32768 i
*> 20.20.20.0/24 0.0.0.0 0 32768 i
*> 30.30.30.0/24 0.0.0.0 0 32768 i
R2#
----------------------
Видно, что для R2 default прилетел с одного интерфейса, а для R1 анонсы с R2 прилетели каждый со своего.
И даже видно, что все 3 сети мы анонсируем на 3 аплинка (фильтруя только):
R2#sh ip bgp ne 192.168.10.1 ad
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.0/24 0.0.0.0 0 32768 i
*> 20.20.20.0/24 0.0.0.0 0 32768 i
*> 30.30.30.0/24 0.0.0.0 0 32768 i
Total number of prefixes 3
R2#sh ip bgp ne 192.168.20.1 ad
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.0/24 0.0.0.0 0 32768 i
*> 20.20.20.0/24 0.0.0.0 0 32768 i
*> 30.30.30.0/24 0.0.0.0 0 32768 i
Total number of prefixes 3
R2#sh ip bgp ne 192.168.30.1 ad
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.0/24 0.0.0.0 0 32768 i
*> 20.20.20.0/24 0.0.0.0 0 32768 i
*> 30.30.30.0/24 0.0.0.0 0 32768 i
Total number of prefixes 3
R2#
----------------------------
НО.
Такая конфигурация не работает, т.е. хост 10.10.10.2/24 не видит 100.100.100.2/24.
Воопбще никто из USERs не видит SERVER.
Трассировка отваливается после первого же хопа с любой из сторон.
В чем может быть проблема?
ПС: реализовывал на EIGRP, заработало, но тоже криво как-то (т.к. сосед в BGP был один, фильтровать тяжелее). Необходима самая простейшая настройка конфига для IGB.
Заранее благодарю.