Ну вот убейте не пойму, почему так происходит… и как от этого избавиться...
Есть два маршрутизатора, между ними два неравноценных линка, и все равно OSPF на R1 к сети 192.168.51.0 выбирает более дорогой маршрут через Tunnel3... Тестовая топология на GNS3 - https://rapidshare.com/files/868212171/OSPF2.rar
R1
interface Tunnel0
ip address 192.168.200.1 255.255.255.252
ip ospf cost 32
ip ospf mtu-ignore
tunnel source 192.168.10.1
tunnel destination 192.168.10.3
!
interface Tunnel3
ip address 192.168.200.17 255.255.255.252
ip ospf cost 4096
ip ospf mtu-ignore
tunnel source 192.168.18.1
tunnel destination 192.168.18.2
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip ospf priority 255
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/0
no switchport
ip address 192.168.18.1 255.255.255.252
!
router ospf 10
router-id 192.168.1.1
log-adjacency-changes
area 10 nssa no-summary
network 192.168.1.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.3 area 10
network 192.168.200.16 0.0.0.3 area 10
default-information originate always metric-type 1
R2
interface Tunnel0
ip address 192.168.200.2 255.255.255.252
ip ospf cost 32
ip ospf mtu-ignore
tunnel source 192.168.10.3
tunnel destination 192.168.10.1
!
interface Tunnel3
ip address 192.168.200.18 255.255.255.252
ip ospf cost 4096
ip ospf mtu-ignore
tunnel source 192.168.18.2
tunnel destination 192.168.18.1
!
interface FastEthernet0/0
ip address 192.168.51.1 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 192.168.10.3 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet1/0
no switchport
ip address 192.168.18.2 255.255.255.252
router ospf 10
router-id 192.168.10.3
log-adjacency-changes
area 10 nssa
redistribute connected metric-type 1 subnets route-map local
network 192.168.200.0 0.0.0.3 area 10
network 192.168.200.16 0.0.0.3 area 10