| 30.06.2015 Выпуск DNS-сервера Knot DNS 2.0 (41 +10) |
Представлен значительный релиз авторитативного DNS-сервера Knot DNS 2.0, разработанного организацией CZ.NIC и используемого для обслуживания доменов первого уровня Чехии. Код сервера распространяется под лицензией GPLv3. Поддерживается работа на большинстве Unix-подобных систем. Из особенностей Knot DNS можно выделить поддержку добавления и удаления зон на лету, возможность полной или инкрементальной передачи зон между серверами, поддержку DDNS (динамические обновления), NSID (RFC 5001), расширений EDNS0 и DNSSEC (включая NSEC3), ограничения интенсивности ответов (RRL)...
|
|
| 30.06.2015 Компания Amazon представила собственную открытую реализацию TLS (32 +27) |
Компания Amazon анонсировала проект s2n, в рамках которого подготовлена компактная и быстрая библиотека с реализацией протоколов SSLv3, TLS1.0, TLS1.1 и TLS1.2. Из методов шифрования поддерживаются 128-и 256-разрядный AES в режимах CBC и GCM, а также 3DES и RC4. Среди других возможностей: DHE, ECDHE, TLS-расширения SNI (Server Name Indicator), ALPN (Application-Layer Protocol Negotiation) и OCS (Online Certificate Status Protocol). Код s2n написан на языке Си и распространяется под лицензией Apache. Библиотека имеет модульную структуру и, помимо встроенных алгоритмов шифрования, может использовать для выполнения операций шифрования внешние криптографические фреймворки, такие как OpenSSL, LibreSSL, BoringSSL и Apple Common Crypto...
|
|
| 30.06.2015 Выпуск дистрибутива Linux Mint 17.2 (54 +25) |
Представлен дистрибутив Linux Mint 17.2, в рамках которого сформирован третий выпуск, основанный на пакетной базе Ubuntu 14.04 LTS. Начиная с ветки Linux Mint 17 дистрибутив перешёл к новой схемe формирования выпусков, подразумевающей использование только релизов Ubuntu с длительным сроком поддержки (LTS). При этом промежуточные выпуски Linux Mint отличаются поставкой новых версий рабочих столов Cinnamon и MATE, а также бэкпортированием некоторых новых версий программ, сохраняя при этом совместимость с репозиториями базового LTS-выпуска Ubuntu. Ветка Linux Mint 17 будет поддерживаться до 2019 года...
|
|
| 30.06.2015 Верховный суд США отказался пересмотреть решение о принадлежности API к интеллектуальной собственности (150 –32) |
Верховный суд США отклонил запрос компании Google на апелляцию, в котором была предпринята попытка инициировать пересмотр решения Федерального апелляционного суда США, отменившего вынесенное в пользу Google судебное решение в тяжбе с Oracle, связанной с Java API. Таким образом остаётся в силе решение апелляционного суда, причислившее программные интерфейсы к объектам авторского права...
|
|
| 29.06.2015 Релиз операционной системы DragonFly BSD 4.2 (33 +22) |
Представлен релиз DragonFlyBSD 4.2, операционной системы с гибридным ядром, созданной в 2003 году с целью альтернативного развития ветки FreeBSD 4.x. Из особенностей DragonFly BSD можно выделить распределённую версионную файловую систему HAMMER, поддержку загрузки "виртуальных" ядер системы как пользовательских процессов, возможность кэширования данных и мета-данных ФС на SSD-накопителях, учитывающие контекст вариантные символические ссылки, возможность заморозки процессов с сохранением их состояния на диске, гибридное ядро, использующее легковесные потоки (LWKT)...
|
|
| 29.06.2015 30 июня при синхронизации времени появится лишняя секунда (70 +20) |
C целью синхронизации с астрономическим временем Земли эталонные мировые атомные часы завтра будут приостановлены на одну секунду, что приведёт к появлению 61 секунды в одной из минут. В прошлый раз подобная синхронизация состоялась в 2012 году и привела к массовым сбоям в серверных системах, в которых была настроена синхронизация точного времени по протоколу NTP. Из-за неготовности обработать появление лишней секунды некоторые системы зацикливались и начинали потреблять излишние ресурсы CPU...
|
|
| 28.06.2015 В LLVM/Clang добавлена техника защиты стека SafeStack (64 +20) |
В компилятор Clang добавлен код подсистемы SafeStack, предназначенной для защиты от типовых ошибок, вызванных повреждением памяти в результате работы со стеком и являющихся причиной большого числа эксплуатируемых уязвимостей (например, в 2014 году в Firefox было выявлено 55 подобных уязвимостей)...
|
|
| 27.06.2015 Выпуск MirageOS 2.5, платформы для запуска приложений поверх гипервизора (24 +4) |
После 11 месяцев разработки представлен релиз облачной операционной системы MirageOS 2.5, которая обеспечивает возможность запуска поверх гипервизора приложений, написанных на языке OCaml. MirageOS позволяет создавать операционные системы одного приложения, содержащие только компоненты, необходимые для запуска одной программы, без необходимости использования традиционных операционных систем с универсальным ядром, утилитами и набором библиотек. В разработке MirageOS принимают участие исследователи из Кембриджского университета, компании Citrix, проектов Xen, FreeBSD, Galois и OCamlPro...
|
|
| 27.06.2015 IETF официально вывел из обихода протокол SSLv3 (22 +16) |
Комитет IETF (Internet Engineering Task Force), занимающийся развитием протоколов и архитектуры интернета, выпустил RFC-7568, переводящий SSLv3 в разряд устаревших протоколов и предупреждающий, что его применение представляет угрозу безопасности систем. Опубликованный RFC требует прекратить применение SSLv3 и запрещает отправку клиентами и серверами пакетов ClientHello/ServerHello c полями ClientHello.client_version/ ServerHello.server_version со значением {03,00}, а в случае получения подобных пакетов регламентирует необходимость разорвать соединение. Вместо SSLv3 рекомендовано использовать TLSv1.2 (RFC 5246)...
|
|
| 27.06.2015 В состав ядра Linux 4.2 принят драйвер AMDGPU (153 +75) |
Как ранее сообщалось, компания AMD планировала перейти к новой стратегии поддержки своих GPU в системе Linux, состоящей в том, что модуль ядра будет полностью открытым, а проприетарный драйвер Catalyst станет лишь набором проприетарных библиотек режима пользователя, реализующих фирменные варианты OpenGL, OpenCL и т.д. Данная инициатива воплотилась в жизнь в апреле и с тех пор драйвер проходил доработку в рамках ветки ядра Linux drm-next...
|
|
| 26.06.2015 Началась работа над openSUSE 42, основанном на коде SUSE Linux Enterprise (29 +31) |
Разработчики проекта openSUSE сообщили о начале подготовки нового релиза дистрибутива, в который будут добавлены некоторые дополнительные наработки, перенесённые из SUSE Linux Enterprise. Изменения ожидаются столь значительные, что разработчики в нерешительности относительно дальнейшей нумерации выпусков: ожидается либо продолжение текущей нумерации, либо совмещение с нумерацией SUSE Linux Enterprise. Кодовое имя нового проекта присвоено в соответствии с названием проекта в Open Build Service за неимением более подходящего названия...
|
|
| 26.06.2015 Джонатан Риддел покинул управляющий совет Kubuntu (66 –22) |
Управляющий совет проекта Ubuntu и управляющий совет Kubuntu опубликовали совместное заявление об урегулировании конфликта, связанного с исключением из управляющего совета Джонатана Риддела (Jonathan Riddell), формального лидера проекта Kubuntu. В заявлении указано, что несмотря на то, что стороны в основном остались при своём мнении о Джонатане Ридделе, обе команды признают, что несмотря на разногласия следует двигаться вперёд и продолжить совместную работу над следующим выпуском, понимая, что KDE важен для Ubuntu так же как и Ubuntu важен для сообщества KDE...
|
|
| 26.06.2015 Выпуск языка программирования Rust 1.1, развиваемого проектом Mozilla (60 +27) |
Спустя месяц с момента публикации первого стабильного релиза доступен выпуск языка программирования Rust 1.1, развиваемого проектом Mozilla, обеспечивающего автоматическое управление памятью и предоставляюшего средства для высокого параллелизма выполнения заданий, при этом обходясь без использования сборщика мусора и runtime. Параллельно с Rust совместно с компанией Samsung развивается экспериментальный браузерный движок Servo, написанный на языке Rust и отличающийся поддержкой многопоточного рендеринга web-страниц и распараллеливанием операций с DOM (Document Object Model)...
|
|
| 25.06.2015 GitHub выпустил среду редактирования кода Atom 1.0 (57 +9) |
GitHub представил первый стабильный релиз редактора кода Atom, который может использоваться как самодостаточное решение, так и в роли технологического стека для построения различных специализированных решений. В частности, на платформе Atom построены среда разработки Visual Studio Code от компании Microsoft и Nuclide от Facebook. Код проекта распространяется под лицензией MIT...
|
|
| 25.06.2015 Увидел свет Eclipse 4.5 "Mars" (24 +13) |
Организация Eclipse Foundation представила ежегодный релиз Eclipse Mars, объединяющего все развиваемые под эгидой Eclipse проекты, такие как платформа Eclipse, набор инструментов для разработчиков на языке Java, средства для управления исходными текстами, визуальные построители GUI и т.п. Для загрузки подготовлено 14 сборок Eclipse, оптимизированных для различных применений платформы, включая варианты для разработчиков, использующих Java SE, Java EE, JavaScript, PHP и C/C++...
|
|
| <<Предыдущие 15 элементов |
| Следующие 15 элементов>> |